Skip to main content
McAfee Enterprise MVISION Cloud

CWPP Agent Supported Platforms and System Requirements

Supported Platforms

Below is a list of supported platforms for the CWPP Agent. Please contact your sales team if you require support for any additional platforms

Number

Vendor

Variant

Version

Addtl. Comments

1

Red Hat

RHEL 8

8.0, 8.1, 8.2, 8.3

 

2 Red Hat RHEL 7 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.8, 7.9  
3 The CentOS Project (affiliated with Red Hat) CentOs 7 7.0.1406, 7.1.1503, 7.2.1511, 7.3.1611, 7.4.1708, 7.5.1804, 7.6.1810, 7.7.1908, 7.8.2003, 7.9.2009  
4 The CentOS Project (affiliated with Red Hat) CentOs 8 8.0.1905, 8.1.1911, 8.2.2004  
5 Fedora Project (sponsored by Red Hat) Fedora 32, 33  
6 Ubuntu Ubuntu Server 16.04.x LTS, 18.04.x LTS, 20.04.x LTS, 20.10  
7 SuSE SLES SLES 12 SP5, SLES 15 SP1, SLES 15 SP2  
8 Amazon AWS Amazon Linux 2 Amazon Linux 2 LTS  
9 Microsoft Windows Server 2012, 2019  Limited Availability - Please contact sales team
10 Microsoft Windows Windows 10, Windows 11 Limited Availability - Please contact sales team

 

System Requirements

Below you find a list of the minimum system requirements when installing the CWPP Agent on a host:

  • 400 MB of RAM for all running plugins and monitoring the workload
  • Administrator privileges to be able to monitor the workloads.
  • CWP Agent on the latest version of kernels can make use of the multicast feature of auditd and coexist with the auditd daemon, CWP Agent on lower kernels expects auditd to be present but it should be disabled
  • Other security products that are installed on the asset may deny the launch of the CWPP Agent. Allow-listing the install folder in /opt and the logging folder in /var/log will ensure smooth functioning of the agent.
  • Was this article helpful?